Virtual Connect Shared Uplink Set + Cisco

Was in Verbindung mit einem HP ProCurve Switch quasi Plug & Play ist, erfordert mit einem Cisco Catalyst Switch etwas mehr Arbeit. ­čśë Die Rede ist von der Anbindung eines Virtual Connect Shared Uplink Set. Nach ein wenig Recherchieren und Probieren konnte ich eine prima Einstellung passend f├╝r Cisco Switche ausmachen.

Die Einrichtung des Share Uplink Sets mit Hilfe des Virtual Connect Managers sollte keine Fragen aufkommen lassen. Das Ergebnis sollte in etwa wie auf nachfolgendem Screenshot aussehen.

vc-shared-uplink-set

Die Gegenseite, sprich den Cisco Switch konfiguriert man dann wie folgt. In meine Fall setze ich einen Cisco Catalyst 3560-E 24-Port  1Gbit mit IOS 12.2(44r)SE3 ein.

interface range GigabitEthernet0/1-4
 description c7k1-uplink-set-1a
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 50,51,79,80
 switchport mode trunk
 switchport nonegotiate
 channel-protocol lacp
 channel-group 1 mode active
 spanning-tree portfast trunk
 spanning-tree bpduguard enable

Besonders wichtig sind die letzten 5 Anweisungen! Mit switchport nonegotiate deaktiviert man das Cisco proprit├Ąre Dynamic Trunking Protokoll (DTP). Damit handelt Cisco Informationen ├╝ber den gebildeten Trunk aus. Aber das HP Virtual Connect Modul ist kein Cisco Switch, also macht diese Angabe definitiv Sinn. Der Befehl channel-protocol lacp aktiviert selbstredend das LACP Protokoll f├╝r den Trunk. Das nachfolgende Kommando channel-group 1 mode active bildet dann den Trunk. In unserem Fall werden die Interfaces GigabitEthernet0/1 bis 4 zum Port-Channel 1 zusammengefasst. Mit mode active aktiviere ich LACP auf allen Interfaces. Ein mode passive tut zwar auch, aber mir ist aufgefallen, das nur eine Verbdinung im Shared Uplink Set den Status Linkes/Active besitzt und alle andere auf Linked/Standy gesetzt sind. Damit w├Ąre die Bandbreite auf nur eine 1Gbit Leitung beschr├Ąnkt. Die letzten beiden Kommandos sind wichtig f├╝r das Netzwerk. Mit Hilfe von spanning-tree portfast trunk schlie├če ich den Trunk aus der Spanning-Tree Konfiguration aus. Der Befehl┬áspanning-tree bpduguard enable sch├╝tzt den Spanning-Tree weiter und verhindert, das BPDU Pakete ├╝ber die Leitungen ausgetauscht werden.

Mit diesen Einstellungen ist der Shared Uplink Set aus dem HP Virtual Connect Modul optimal im Netzwerk angebunden. In meinem Falle habe ich zwei Virtual Connect 1/10 GB Ethernet Module im Einsatz und habe deswegen auch zwei Shared Uplink Sets eingerichtet, die jeweils an einen eigenen Switch angebunden sind. Die Switche untereinander sind mit 10 GBit Uplinks verbunden und ├╝ber eine entsprechend Multiple Spanning Tree (MST) Konfiguration habe ich die VLANs auf zwei Instanzen aufgeteilt. Damit ergibt sich rein rechnerisch eine aggregierte Bandbreite von 16 GBit. ­čśë Das sollte in den meisten F├Ąlle mehr als genug sein. ­čśÇ

2 thoughts on “Virtual Connect Shared Uplink Set + Cisco

  1. Hallo,

    coole Sache. Dir ist aber hoffentlich klar, dass bei Ausfall eines VC Ethernet Module die Uplinks f├╝r die vier Networks, die das UPLINK_SET_1_A verwenden, verloren gehen.

    Wenn die NICs auf den Blade Servern entsprechend geteamed bzw. gebondet sind, ist das verkraftbar, Du solltest aber zur Sicherheit auch Smart Link (Link State Propagation) aktivieren.

    1. Hallo,

      ich w├╝rde mal frech sagen, selbstverst├Ąndlich wei├č ich das! Meine Netze und Server sind auch entsprechend konfiguriert. Aber in Verbindung mit STP ist noch einiges an Optimierungsbedarf vorhanden. Darum baue ich zur Zeit auch zwei gro├če Cisco 6500 Switche auf um die Konfiguration zu optimieren. Auch das Thema Smart-Link werde ich nochmal evaluieren. Insbesondere ein Hypervisor mit Round-Robin Load Balancing Verfahren stellt ganz andere Anforderungen als ein direkt aufs Blech installierter Windows/Linux Server. Aber dazu mehr, sobald ich meine Ciscos fertig habe. ­čśë Ein ausf├╝hrlicher Bericht ist schon laaaaaaange in Planung!

Comments are closed.